Description
Top Next

Full Image Info

splash 300x210

Full Image Info is an easy to use program targeted to view and retrieve information about images and photos taken with digital cameras.

Many common image formats are supported including JPEG, TIFF, BMP, GIF, JPEG2000, PCX, CUR, ICO, PNG, TGA, PXM, and a variety of information can be retrieved about each, including resolution, width, height and color mode.

Full Image Info can also provide detailed EXIF information about photos (model, exposure program, shutter speed value, aperture value, etc.), IPTC information and more.

Features


Features
Previous Top Next

Currently supported file formats

TIFF Bitmap (TIF;TIFF;FAX;G3N;G3F)
JPEG Bitmap (JPG;JPEG;JPE)
PaintBrush (PCX)
Windows Bitmap (BMP;DIB;RLE)
Windows Icon (ICO)
Windows Cursor (CUR)
Portable Network Graphics (PNG)
Targa Bitmap (TGA;TARGA;VDA;ICB;VST;PIX)
Portable Pixmap, GreyMap, BitMap (PXM;PPM;PGM;PBM)
JPEG2000 (JP2)
CompuServe Bitmap (GIF)

Full Image Info returns the following common information:

File name of the last loaded image.
FileType returns a textual description of the file type and other file format specific properties.
Width of the image (pixels).
Height of the image (pixels).
BitsPerSample. Bits number each sample has.
SamplesPerPixel. Samples for each pixel.
ColorMapCount is the number of entries in ColorMap array.
DpiX. Specifies the DpiX (horizontal dots per inch) of the image.
DpiY. Specifies the DpiY (vertical dots per inch) of the image.

Some image types return extra information:

BMP
BMP_Compression
BMP_Version

GIF
GIF_Background
GIF_DelayTime
GIF_FlagTranspColor
GIF_ImageIndex
GIF_ImageCount
GIF_Interlaced
GIF_Ratio
GIF_TranspColor
GIF_Version
GIF_WinHeight
GIF_WinWidth
GIF_XPos
GIF_YPos
GIF_Comments

JPEG
JPEG_ColorSpace
JPEG_DCTMethod
JPEG_OptimalHuffman
JPEG_Progressive
JPEG_Quality
JPEG_Smooth
JPEG_Scale
JPEG_Scale_Used
JPEG_MarkerList
JPEG_WarningTot
JPEG_WarningCode
JPEG_OriginalWidth
JPEG_OriginalHeight

JPEG 2000
JPEG2000_ColorSpace
JPEG2000_Rate
JPEG2000_ScalableBy

PCX
PCX_Compression
PCX_Version

TIFF
TIFF_Compression
TIFF_DocumentName
TIFF_EnableAdjustOrientation
TIFF_ImageDescription
TIFF_ImageIndex
TIFF_ImageCount
TIFF_PageCount
TIFF_PageName
TIFF_PageNumber
TIFF_PhotometInterpret
TIFF_PlanarConf
TIFF_XPos
TIFF_YPos
TIFF_Orientation

CUR
CUR_ImageIndex
CUR_XHotSpot
CUR_YHotSpot
CUR_Background

ICO
ICO_ImageIndex
ICO_Background

PNG
PNG_Interlaced
PNG_Background
PNG_Filter
PNG_Compression

TGA
TGA_XPos
TGA_YPos
TGA_Compressed
TGA_Descriptor
TGA_Author
TGA_Date
TGA_ImageName
TGA_Background
TGA_AspectRatio
TGA_Gamma
TGA_GrayLevel

PXM
PXM_Comments

IPTC_Info

EXIF information
EXIF_ImageDescription
EXIF_Model
EXIF_Orientation
EXIF_XResolution
EXIF_YResolution
EXIF_ResolutionUnit
EXIF_Software
EXIF_DateTime
EXIF_WhitePoint
EXIF_PrimaryChromaticities
EXIF_YCbCrCoefficients
EXIF_YCbCrPositioning
EXIF_ReferenceBlackWhite
EXIF_Copyright
EXIF_ExposureTime
EXIF_FNumber
EXIF_ExposureProgram
EXIF_ISOSpeedRatings
EXIF_ExifVersion
EXIF_DateTimeOriginal
EXIF_DateTimeDigitized
EXIF_CompressedBitsPerPixel
EXIF_ShutterSpeedValue
EXIF_ApertureValue
EXIF_BrightnessValue
EXIF_ExposureBiasValue
EXIF_MaxApertureValue
EXIF_SubjectDistance
EXIF_MeteringMode
EXIF_LightSource
EXIF_Flash
EXIF_FocalLength
EXIF_SubsecTime
EXIF_SubsecTimeOriginal
EXIF_SubsecTimeDigitized
EXIF_FlashPixVersion
EXIF_ColorSpace
EXIF_ExifImageWidth
EXIF_ExifImageHeight
EXIF_RelatedSoundFile
EXIF_FocalPlaneXResolution
EXIF_FocalPlaneYResolution
EXIF_FocalPlaneResolutionUnit
EXIF_ExposureIndex
EXIF_SensingMethod
EXIF_FileSource
EXIF_SceneType
EXIF_UserComment
EXIF_UserCommentCode


What's new

Full Image Info 1.1
January, 15, 2004

EXIF and IPTC information have been added.

Full Image Info 1.0
December, 01, 2003

First version.


License

License for use and distribution

Full Image Info is distributed as try-before-you-buy.

This means:

1. All rights to Full Image Info are exclusively owned by the author - GraphicRegion.com.

2. Anyone may use this software during a test period of 30 days. Following this test period of 30 days or less, if you wish to continue to use Full Image Info, you MUST register.

3. Once registered, the user is granted a non-exclusive license to use Able Graphic Manager on one computer, for any legal purpose, at a time.

We have two types of licenses: personal and business. With the Personal License ($19.95), you can use the program for non-commercial purposes in non-business, non commercial environment. To use the program in a corporate, government or business environment, you should purchase a Business License - $29.95(US).

The registered Full Image Info software may not be rented or leased, but may be permanently transferred, if the person receiving it agrees to terms of this license. If the software is an update, the transfer must include the update and all previous versions.

4. The Full Image Info unregistered version, may be freely distributed, with exceptions noted below, provided the distribution package is not modified.

5. To register you must complete the online registration form and pay registration fee.

6. Full Image Info IS DISTRIBUTED "AS IS". NO WARRANTY OF ANY KIND IS EXPRESSED OR IMPLIED. YOU USE AT YOUR OWN RISK. THE AUTHOR WILL NOT BE LIABLE FOR DATA LOSS, DAMAGES, LOSS OF PROFITS OR ANY OTHER KIND OF LOSS WHILE USING OR MISUSING THIS SOFTWARE.

7. You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or transfer the licensed program, or any subset of the licensed program, except as provided for in this agreement. Any such unauthorized use shall result in immediate and automatic termination of this license and may result in criminal and/or civil prosecution. All rights not expressly granted here are reserved by GraphicRegion.com.

8. Installing and using Full Image Info signifies acceptance of these terms and conditions of the license.

9. If you do not agree with the terms of this license you must remove Full Image Info files from your storage devices and cease to use the product.

Thank you for using Full Image Info.


Registration

Full Image Info is a shareware software.

It costs $19.95 (personal license) or $29.95 (business license).

You only pay a one-time $19.95 or 29.95 charge for the software.

Transactions are Processed by ShareIt or RegSoft - The Largest online Payment Processors.

Your Payment Information is Secure - We don't even get your information.

ShareIt or RegSoft uses Secure Server for your Protection.

Benefits of registration
1. Using after the evaluation period (30 days).
2. No "DEMO" shows.
3. Free upgrades (you will get all the future versions free of charge).
4. Free support.

If you would like to register Full Image Info visit

http://www.graphicregion.com/purchase.htm

Buy Now:

personal license

business license


Contact us

You can download the latest version of Full Image Info from the website:

http://www.graphicregion.com/imageinfo.zip

Send your questions, comments and bug reports to

support@graphicregion.com


Main Window

Window


Common Info

File name of the last loaded image.

FileType returns a textual description of the file type and other file format specific properties.

Width of the image (pixels).
Height of the image (pixels).

BitsPerSample. Bits number each sample has.
Values handles are:
1 for black & white
2..7 for colormapped bitmap (from 4 to 256 colors)
8 for colormapped or true color).

SamplesPerPixel. Samples for each pixel.
This property can be only 1 for colormapped images or 3 for true color image.

ColorMapCount is the number of entries in ColorMap array.

DpiX. Specifies the DpiX (horizontal dots per inch) of the image.
DpiY. Specifies the DpiY (vertical dots per inch) of the image.


Special Info

Some image types return extra information.


BMP

BMP_Compression
Specifies compression method.
BMP_UNCOMPRESSED, BMP_RLE

BMP_Version
Specifies version of the BMP file.
BMP_BM is old Windows bitmap.
BMP_BM3 is Windows 3.x or newer bitmap.
BMP_BMOS2V1 is IBM OS/2 version 1.x bitmap.
BMP_BMOS2V2 is IBM OS/2 version 2.x bitmap.


GIF

GIF_Background
GIF_Background is the background color of the GIF.

GIF_DelayTime
GIF_DelayTime is the time (in 1/100 s) the frame remains showed.

GIF_FlagTranspColor
If True the GIF_TranspColor color is valid (the image has a transparency color).

GIF_ImageIndex
The index (from 0) of the image.

GIF_ImageCount
Specifies the image count of the last GIF loaded.

GIF_Interlaced
If True the image is interlaced.

GIF_Ratio
Aspect ratio.

GIF_TranspColor
GIF_TranspColor is the transparency coolor (If GIF_FlagTranspColor is True).

GIF_Version
GIF_Version can be 'GIF89a' or 'GIF87a'.

GIF_WinHeight
GIF_WinHeight is the height of the window where GIF is showed.

GIF_WinWidth
GIF_WinWidth is the width of the window where GIF is showed.

GIF_XPos
GIF_XPos is the top-left X coordinate where the frame will be showed.

GIF_YPos
GIF_YPos is the top-left Y coordinate where the frame will be showed.

GIF_Comments
Contains the text comments contained in a GIF file.


JPEG

JPEG_ColorSpace
Specify the loaded color space.
JPEG_RGB is separate RGB channels.
JPEG_GRAYLEV is unique intensity channel (gray levels).
JPEG_YCbCr three channels (CCIR Recommendation 601-1)
JPEG_CMYK four channels (Cyan Magenta Yellow Black) - linear convertion
JPEG_YCbCrK four channels (YCbCr and Black)

JPEG_DCTMethod
Specify the DCT method.
JPEG_ISLOW is slow but accurate integer algorithm.
JPEG_IFAST is faster, less accurate integer method.
JPEG_FLOAT is a floating-point method (machine dependent).

JPEG_OptimalHuffman
Specifies if jpeg compressor have to use an optimal huffman table (more compression)), instead standard table.

JPEG_Progressive
Specifies if this is a progressive jpeg.

JPEG_Quality
Quality factor, from 1 to 100. The higher the value, the better the image quality, and the larger resultant memory needed.

JPEG_Smooth
Smoothing factor (0 is none, 100 is max). If JPEG_Smooth is not zero, the jpeg compressor smooth the image before compress it. This improves compression.

JPEG_Scale
JPEGScale defines the sizes of loaded JPEG image. This proprety affects the speed of load.
Allowed values are:
JPEG_AUTOCALC : self calculates JPEGScale to mach Params.Width and Params.Height properties;
JPEG_FULLSIZE : full size image (default). Slow loading.
JPEG_HALF : 1/2 of the full size;
JPEG_QUARTER : 1/4 of the full size;
JPEG_EIGHTH : 1/8 of the full size. Very fast loading.

JPEG_MarkerList
JPEG_MarkerList contains a list of markers contained in a JPEG file. JPEG markers can contains text, objects and images. Applications can read raw markers from JPEG_MarkerList.

JPEG_WarningTot
JPEG_WarningTot is the count of all warnings encountered during loading a Jpeg. We suggest to use Aborting to see if the image is corrupted.

JPEG_WarningCode
JPEG_WarningCode is the last warning code encountered during loading a Jpeg.

JPEG_OriginalWidth
JPEG_OriginalWidth specifies the original width when the jpeg image is scaled (using JPEG_Scale).

JPEG_OriginalHeight
JPEG_OriginalHeight specifies the original height when the jpeg image is scaled (using JPEG_Scale).


JPEG 2000

JPEG2000_ColorSpace
Specifies the loaded color space.
Allowed values:
J2000_GRAYLEV : gray scale image
J2000_RGB : RGB image
J2000_YcbCr : YcbCr image (currently supported only for load)

JPEG2000_Rate
Specifies the compression rate to apply. Allowed values from 0 to 1, where 1 is no compression (lossless mode).

JPEG2000_ScalableBy
Specifies the progression order.
It can be:
J2000_Rate : layer-resolution-component-position (LRCP) progressive (i.e., rate scalable)
J2000_Resolution : resolution-layer-component-position (RLCP) progressive (i.e., resolution scalable)


PCX

PCX_Compression
PCX_Compression is the compression type for PCX image format.
PCX_UNCOMPRESSED is uncompressed PCX (incompatible with most PCX readers).
PCX_RLE is compressed PCX (standard PCX).

PCX_Version
PCX version (5 is the default).


TIFF

TIFF_Compression
Specifies the compression type for TIFF image format.
TIFF_UNCOMPRESSED is uncompressed TIFF
TIFF_CCITT1D is bilevel Huffman compression.
TIFF_G3FAX1D is bilevel Group 3 CCITT compression, monodimensional.
TIFF_G3FAX2D is bilevel Group 3 CCITT compression, bidimensional.
TIFF_G4FAX is bilevel Group 4 CCITT compression, bidimensional.
TIFF_OLDJPEG is ver.6.0 jpeg compression (unsupported).
TIFF_JPEG is jpeg compression (unsupported).
TIFF_PACKBITS is RLE compression.
TIFF_UNKNOWN is an unknown compression

TIFF_DocumentName
Specifiy the document name field of a TIFF image format.

TIFF_EnableAdjustOrientation
When TIFF_EnableAdjustOrientation is True program rotate loaded image as specified in the TIFF file.

TIFF_ImageDescription
Specifiy the image description field of a TIFF image format.

TIFF_ImageIndex
TIFF_ImageIndex is the index (from 0) of the image.

TIFF_ImageCount
Specifies the image count of the last TIFF loaded.

TIFF_PageCount
Number of pages in TIFF file.

TIFF_PageName
Page name field in TIFF image format.

TIFF_PageNumber
Page number.

TIFF_PhotometInterpret
Photometric interpretation.
TIFF_WHITEISZERO
TIFF_BLACKISZERO
TIFF_RGB
TIFF_RGBPALETTE
TIFF_TRANSPMASK
TIFF_CMYK
TIFF_YCBCR
TIFF_CIELAB

TIFF_PlanarConf
Planar configuration.

TIFF_XPos
X top-left position of the original scanned image.

TIFF_YPos
Ytop-left position of the original scanned image.

TIFF_Orientation
The orientation of the original image.
Allowed values:
1 = The 0th row represents the visual top of the image, and the 0th column represents the visual left-hand side.
2 = The 0th row represents the visual top of the image, and the 0th column represents the visual right-hand side.
3 = The 0th row represents the visual bottom of the image, and the 0th column represents the visual right-hand side.
4 = The 0th row represents the visual bottom of the image, and the 0th column represents the visual left-hand side.
5 = The 0th row represents the visual left-hand side of the image, and the 0th column represents the visual top.
6 = The 0th row represents the visual right-hand side of the image, and the 0th column represents the visual top.
7 = The 0th row represents the visual right-hand side of the image, and the 0th column represents the visual bottom.
8 = The 0th row represents the visual left-hand side of the image, and the 0th column represents the visual bottom.


CUR

CUR_ImageIndex
The index (from 0) of the image. A CUR file can contains multple images inside.

CUR_XHotSpot
The hot spot point of the cursor image.

CUR_YHotSpot
The hot spot point of the cursor image.

CUR_Background
CUR_Background is the background color where to merge loaded image.


ICO

ICO_ImageIndex
The index (from 0) of the image. An ICO file can contains multple images inside.

ICO_Background
ICO_Background is the background color where to merge loaded image.


PNG

PNG_Interlaced
If True the image is interlaced.

PNG_Background
Specifies the background color of the image.

PNG_Filter
Set the filter to apply. This can have a significant impact on the size and encoding speed and a somewhat lesser impact on the decoding speed of an image.
PNG_FILTER_NONE
PNG_FILTER_SUB
PNG_FILTER_PAETH

PNG_Compression
PNG_Compression changes how much time PNG-compressor spends on trying to compress the image data.
This property accept values from 0 (no compression) to 9 (best compression).


TGA

TGA_XPos
TGA_XPos is the top-left X coordinate where the image will be showed.

TGA_YPos
TGA_YPos is the top-left Y coordinate where the image will be showed.

TGA_Compressed
Set TGA_Compressed property to True to compress TGA image (RLE compression).

TGA_Descriptor
TGA_Descriptor contains the descriptor of the TGA file.

TGA_Author
TGA_Author contains the author name of the TGA file.

TGA_Date
TGA_Date contains the date/time creation of the TGA file.

TGA_ImageName
TGA_ImageName contains the image name of the TGA file.

TGA_Background
TGA_Background contains the image background (or transparency) color.

TGA_AspectRatio
TGA_AspectRatio contains the pixel aspect ratio (pixel width/height) of the TGA image

TGA_Gamma
TGA_Gamma contains the gamma value of the TGA image

TGA_GrayLevel
If TGA_GrayLevel is True the image will be saved as gray levels.


PXM

PXM_Comments
PXM_Comments contains a list of the comments found inside (or to write in) PPM, PBM or PGM file.


IPTC info

IPTC_Info contains a list of IPTC informations contained in a file.
IPTC records can contains text, objects and images.
Applications can read informations from IPTC_Info.

Each IPTC_Info item has a record number and a dataset number.
These values specify the type of datas contained in the item, according to IPTC - NAA Information Intechange Model Version 4 (look at www.iptc.org).


EXIF information
Previous Top

EXIF_ImageDescription
Describes the image

EXIF_Model
Shows model number of digicam

EXIF_Orientation
The orientation of the camera relative to the scene, when the image was captured
1 top left side
2 top right side
3 bottom right side
4 bottom left side
5 left side top
6 right side top
7 right side bottom
8 left side bottom

EXIF_XResolution, EXIF_YResolution
Display/Print resolution of image.
Default value is 1/72inch, but it has no mean because personal computer doesn't use this value to display/print out.

EXIF_ResolutionUnit
Unit of XResolution/YResolution.
1 means no-unit
2 means inch
3 means centimeter

EXIF_Software
Shows firmware(internal software of digicam) version number

EXIF_DateTime
Date/Time of image was last modified.
Data format is "YYYY:MM:DD HH:MM:SS". If clock has not set or digicam doesn't have clock, the field may be filled with spaces. In usual, it has the same value of DateTimeOriginal

EXIF_WhitePoint
Defines chromaticity of white point of the image.
If the image uses CIE Standard Illumination D65(known as international standard of 'daylight'), the values are '3127/10000,3290/10000'.

EXIF_PrimaryChromaticities
Defines chromaticity of the primaries of the image.
If the image uses CCIR Recommendation 709 primaries, values are '640/1000,330/1000,300/1000,600/1000,150/1000,0/1000'.

EXIF_YCbCrCoefficients
When image format is YCbCr, this value shows a constant to translate it to RGB format.
In usual, values are '0.299/0.587/0.114'.

EXIF_YCbCrPositioning
When image format is YCbCr and uses 'Subsampling' (cropping of chroma data, all the digicam do that), defines the chroma sample point of subsampling pixel array.
1 means the center of pixel array
2 means the datum point.

EXIF_ReferenceBlackWhite
Shows reference value of black point/white point.
In case of YCbCr format, first 2 show black/white of Y, next 2 are Cb, last 2 are Cr. In case of RGB format, first 2 show black/white of R, next 2 are G, last 2 are B.

EXIF_Copyright
Shows copyright information

EXIF_ExposureTime
Exposure time (reciprocal of shutter speed). Unit is second.

EXIF_FNumber
The actual F-number(F-stop) of lens when the image was taken.

EXIF_ExposureProgram
Exposure program that the camera used when image was taken.
1 means manual control
2 program normal
3 aperture priority
4 shutter priority
5 program creative (slow program)
6 program action(high-speed program)
7 portrait mode
8 landscape mode.

EXIF_ISOSpeedRatings
CCD sensitivity equivalent to Ag-Hr film speedrate.

EXIF_ExifVersion
Exif version number.
If the picture is based on Exif V2.1, value is "0210".

EXIF_DateTimeOriginal
Date/Time of original image taken.
This value should not be modified by user program. Data format is "YYYY:MM:DD HH:MM:SS". If clock has not set or digicam doesn't have clock, the field may be filled with spaces. In the Exif standard, this tag is optional, but it is mandatory for DCF.

EXIF_DateTimeDigitized
Date/Time of image digitized.
Usually, it contains the same value of DateTimeOriginal. Data format is "YYYY:MM:DD HH:MM:SS". If clock has not set or digicam doesn't have clock, the field may be filled with spaces. In the Exif standard, this tag is optional, but it is mandatory for DCF.

EXIF_CompressedBitsPerPixel
The average compression ratio of JPEG (rough estimate)

EXIF_ShutterSpeedValue
Shutter speed by APEX value.
To convert this value to ordinary 'Shutter Speed'; calculate this value's power of 2, then reciprocal.
For example, if the ShutterSpeedValue is '4', shutter speed is 1/(24)=1/16 second.

EXIF_ApertureValue
The actual aperture value of lens when the image was taken. Unit is APEX.
To convert this value to ordinary F-number (F-stop), calculate this value's power of root 2 (=1.4142).
For example, if the ApertureValue is '5', F-number is 1.41425 = F5.6.

EXIF_BrightnessValue
Brightness of taken subject, unit is APEX.
To calculate Exposure(Ev) from BrigtnessValue(Bv), you must add SensitivityValue(Sv).
Ev=Bv+Sv Sv=log2(ISOSpeedRating/3.125)
ISO100:Sv=5, ISO200:Sv=6, ISO400:Sv=7, ISO125:Sv=5.32.

EXIF_ExposureBiasValue
Exposure bias(compensation) value of taking picture. Unit is APEX(EV).

EXIF_MaxApertureValue
Maximum aperture value of lens.
You can convert to F-number by calculating power of root 2 (same process of ApertureValue).

EXIF_SubjectDistance
Distance to focus point, unit is meter.

EXIF_MeteringMode
Exposure metering method.
0 means unknown
1 average
2 center weighted average
3 spot
4 multi-spot
5 multi-segment
6 partial
255 other.

EXIF_LightSource
Light source, actually this means white balance setting.
0 means unknown
1 daylight
2 fluorescent
3 tungsten
10 flash
17 standard light A
18 standard light B
19 standard light C
20 D55
21 D65
22 D75
255 other.

EXIF_Flash
0 means flash did not fire
1 flash fired
5 flash fired but strobe return light not detected
7 flash fired and strobe return light detected

EXIF_FocalLength
Focal length of lens used to take image. Unit is millimeter.

EXIF_SubsecTime, EXIF_SubsecTimeOriginal, EXIF_SubsecTimeDigitized
Some of digicam can take 2~30 pictures per second, but DateTime/DateTimeOriginal/DateTimeDigitized tag can't record the sub-second time. SubsecTime tag is used to record it.
For example, DateTimeOriginal = "1996:09:01 09:15:30",
SubSecTimeOriginal = "130",
Combined original time is "1996:09:01 09:15:30.130"

EXIF_FlashPixVersion
Stores FlashPix version.
If the image data is based on FlashPix formar Ver.1.0, value is "0100".

EXIF_ColorSpace
Defines Color Space. DCF image must use sRGB color space so value is always '1'. If the picture uses the other color space, value is '65535':Uncalibrated.

EXIF_ExifImageWidth, EXIF_ExifImageHeight
Size of main image.

EXIF_RelatedSoundFile
If this digicam can record audio data with image, shows name of audio data.

EXIF_FocalPlaneXResolution, EXIF_FocalPlaneYResolution
Pixel density at CCD's position.
If you have MegaPixel digicam and take a picture by lower resolution(e.g.VGA mode), this value is re-sampled by picture resolution. In such case, FocalPlaneResolution is not same as CCD's actual resolution.

EXIF_FocalPlaneResolutionUnit
Unit of FocalPlaneXResoluton/FocalPlaneYResolution.
1 means no-unit
2 inch
3 centimeter.

Note:Some of Fujifilm's digicam(e.g.FX2700,FX2900,Finepix4700Z/40i etc) uses value '3' so it must be 'centimeter', but it seems that they use a '8.3mm?'(1/3in.?) to their ResolutionUnit. Fuji's BUG? Finepix4900Z has been changed to use value '2' but it doesn't match to actual value also.

EXIF_ExposureIndex
Same as ISOSpeedRatings but data type is unsigned rational. Only Kodak's digicam uses this tag instead of ISOSpeedRating.

EXIF_SensingMethod
Shows type of image sensor unit. '2' means 1 chip color area sensor, most of all digicam use this type.

EXIF_FileSource
Indicates the image source. Value '03' means the image source is digital still camera.

EXIF_SceneType
Indicates the type of scene. Value '01' means that the image was directly photographed.


.topic 4
  Full Image Info

Full Image Info is an easy to use program targeted to view and retrieve information about images and photos taken with digital cameras.

Many common image formats are supported including JPEG, TIFF,  BMP, GIF,  JPEG2000, PCX, CUR, ICO, PNG, TGA, PXM, and a variety of information can be retrieved about each, including resolution, width, height and color mode.

Full Image Info can also provide detailed EXIF information about photos (model, exposure program, shutter speed value, aperture value, etc.), IPTC information and more.

Features

.topic 6
Currently supported file formats

  TIFF Bitmap (TIF;TIFF;FAX;G3N;G3F)
  JPEG Bitmap (JPG;JPEG;JPE)
  PaintBrush (PCX)
  Windows Bitmap (BMP;DIB;RLE)
  Windows Icon (ICO)
  Windows Cursor (CUR)
  Portable Network Graphics (PNG)
  Targa Bitmap (TGA;TARGA;VDA;ICB;VST;PIX)
  Portable Pixmap, GreyMap, BitMap (PXM;PPM;PGM;PBM)
  JPEG2000 (JP2)
  CompuServe Bitmap (GIF)

Full Image Info returns the following common information:

File name of the last loaded  image.
FileType returns a textual description of the file type and other file format specific properties.
Width of the image (pixels).
Height of the image (pixels).
BitsPerSample. Bits number each sample has.
SamplesPerPixel. Samples for each pixel.
ColorMapCount is the number of entries in ColorMap array.
DpiX. Specifies the DpiX (horizontal dots per inch) of the image.
DpiY. Specifies the DpiY (vertical dots per inch) of the image.

Some image types return extra information:

BMP
BMP_Compression
BMP_Version

GIF
GIF_Background
GIF_DelayTime
GIF_FlagTranspColor
GIF_ImageIndex
GIF_ImageCount
GIF_Interlaced
GIF_Ratio
GIF_TranspColor
GIF_Version
GIF_WinHeight
GIF_WinWidth
GIF_XPos
GIF_YPos
GIF_Comments

JPEG
JPEG_ColorSpace
JPEG_DCTMethod
JPEG_OptimalHuffman
JPEG_Progressive
JPEG_Quality
JPEG_Smooth
JPEG_Scale
JPEG_Scale_Used
JPEG_MarkerList
JPEG_WarningTot
JPEG_WarningCode
JPEG_OriginalWidth
JPEG_OriginalHeight

JPEG 2000
JPEG2000_ColorSpace
JPEG2000_Rate
JPEG2000_ScalableBy

PCX
PCX_Compression
PCX_Version

TIFF
TIFF_Compression
TIFF_DocumentName
TIFF_EnableAdjustOrientation
TIFF_ImageDescription
TIFF_ImageIndex
TIFF_ImageCount
TIFF_PageCount
TIFF_PageName
TIFF_PageNumber
TIFF_PhotometInterpret
TIFF_PlanarConf
TIFF_XPos
TIFF_YPos
TIFF_Orientation

CUR
CUR_ImageIndex
CUR_XHotSpot
CUR_YHotSpot
CUR_Background

ICO
ICO_ImageIndex
ICO_Background

PNG
PNG_Interlaced
PNG_Background
PNG_Filter
PNG_Compression

TGA
TGA_XPos
TGA_YPos
TGA_Compressed
TGA_Descriptor
TGA_Author
TGA_Date
TGA_ImageName
TGA_Background
TGA_AspectRatio
TGA_Gamma
TGA_GrayLevel

PXM
PXM_Comments

IPTC_Info

EXIF information
EXIF_ImageDescription
EXIF_Model
EXIF_Orientation
EXIF_XResolution
EXIF_YResolution
EXIF_ResolutionUnit
EXIF_Software
EXIF_DateTime
EXIF_WhitePoint
EXIF_PrimaryChromaticities
EXIF_YCbCrCoefficients
EXIF_YCbCrPositioning
EXIF_ReferenceBlackWhite
EXIF_Copyright
EXIF_ExposureTime
EXIF_FNumber
EXIF_ExposureProgram
EXIF_ISOSpeedRatings
EXIF_ExifVersion
EXIF_DateTimeOriginal
EXIF_DateTimeDigitized
EXIF_CompressedBitsPerPixel
EXIF_ShutterSpeedValue
EXIF_ApertureValue
EXIF_BrightnessValue
EXIF_ExposureBiasValue
EXIF_MaxApertureValue
EXIF_SubjectDistance
EXIF_MeteringMode
EXIF_LightSource
EXIF_Flash
EXIF_FocalLength
EXIF_SubsecTime
EXIF_SubsecTimeOriginal
EXIF_SubsecTimeDigitized
EXIF_FlashPixVersion
EXIF_ColorSpace
EXIF_ExifImageWidth
EXIF_ExifImageHeight
EXIF_RelatedSoundFile
EXIF_FocalPlaneXResolution
EXIF_FocalPlaneYResolution
EXIF_FocalPlaneResolutionUnit
EXIF_ExposureIndex
EXIF_SensingMethod
EXIF_FileSource
EXIF_SceneType
EXIF_UserComment
EXIF_UserCommentCode

.topic 16
Full Image Info 1.1
January, 15, 2004

EXIF and IPTC information have been added.

Full Image Info 1.0
December, 01, 2003

First version.

.topic 8
License for use and distribution

Full Image Info is distributed as try-before-you-buy.

This means:

1. All rights to Full Image Info are exclusively owned by the author - GraphicRegion.com.

2. Anyone may use this software during a test period of 30 days. Following this test period of 30 days or less, if you wish to continue to use Full Image Info, you MUST register.

3. Once registered, the user is granted a non-exclusive license to use Able Graphic Manager on one computer, for any legal purpose, at a time.

We have two types of licenses: personal and business. With the Personal License ($19.95), you can use the program for non-commercial purposes in non-business, non commercial environment. To use the program in a corporate, government or business environment, you should purchase a Business License - $29.95(US).

The registered Full Image Info software may not be rented or leased, but may be permanently transferred, if the person receiving it agrees to terms of this license. If the software is an update, the transfer must include the update and all previous versions.

4. The Full Image Info unregistered version, may be freely distributed, with exceptions noted below, provided the distribution package is not modified.

5. To register you must complete the online registration form and pay registration fee.

6. Full Image Info IS DISTRIBUTED "AS IS". NO WARRANTY OF ANY KIND IS EXPRESSED OR IMPLIED. YOU USE AT YOUR OWN RISK. THE AUTHOR WILL NOT BE LIABLE FOR DATA LOSS, DAMAGES, LOSS OF PROFITS OR ANY OTHER KIND OF LOSS WHILE USING OR MISUSING THIS SOFTWARE.

7. You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or transfer the licensed program, or any subset of the licensed program, except as provided for in this agreement. Any such unauthorized use shall result in immediate and automatic termination of this license and may result in criminal and/or civil prosecution. All rights not expressly granted here are reserved by GraphicRegion.com.

8. Installing and using Full Image Info signifies acceptance of these terms and conditions of the license.

9. If you do not agree with the terms of this license you must remove Full Image Info files from your storage devices and cease to use the product.

Thank you for using Full Image Info.

.topic 14
Full Image Info is a shareware software.

It costs $19.95 (personal license) or $29.95 (business license).

You only pay a one-time $19.95 or 29.95 charge for the software.

Transactions are Processed by ShareIt or RegSoft - The Largest online Payment Processors.

Your Payment Information is Secure - We don't even get your information.

ShareIt or RegSoft uses Secure Server for your Protection.

Benefits of registration
1. Using after the evaluation period (30 days).
2. No "DEMO" shows.
3. Free upgrades (you will get all the future versions free of charge).
4. Free support.

If you would like to register Full Image Info visit

http://www.graphicregion.com/purchase.htm

Buy Now:

personal license

business license

.topic 3
You can download the latest version of Full Image Info from the website:

http://www.graphicregion.com/imageinfo.zip

Send your questions, comments and bug reports to

support@graphicregion.com

.topic 11

.topic 20
File name of the last loaded  image.

FileType returns a textual description of the file type and other file format specific properties.

Width of the image (pixels).
Height of the image (pixels).

BitsPerSample. Bits number each sample has.
Values handles are:
  1 for black & white
  2..7 for colormapped bitmap (from 4 to 256 colors)
  8 for colormapped or true color).

SamplesPerPixel. Samples for each pixel.
This property can be only 1 for colormapped images or 3 for true color image.

ColorMapCount is the number of entries in ColorMap array.

DpiX. Specifies the DpiX (horizontal dots per inch) of the image.
DpiY. Specifies the DpiY (vertical dots per inch) of the image.

.topic 30
Some image types return extra information.

.topic 32
BMP_Compression
Specifies compression method.
BMP_UNCOMPRESSED, BMP_RLE

BMP_Version
Specifies version of the BMP file.
BMP_BM is old Windows bitmap.
BMP_BM3 is Windows 3.x or newer bitmap.
BMP_BMOS2V1 is IBM OS/2 version 1.x bitmap.
BMP_BMOS2V2 is IBM OS/2 version 2.x bitmap.

.topic 34
GIF_Background
GIF_Background is the background color of the GIF.

GIF_DelayTime
GIF_DelayTime is the time (in 1/100 s) the frame remains showed.

GIF_FlagTranspColor
If True the GIF_TranspColor color is valid (the image has a transparency color).

GIF_ImageIndex
The index (from 0) of the image.

GIF_ImageCount
Specifies the image count of the last GIF loaded.

GIF_Interlaced
If True the image is interlaced.

GIF_Ratio
Aspect ratio.

GIF_TranspColor
GIF_TranspColor is the transparency coolor (If GIF_FlagTranspColor is True).

GIF_Version
GIF_Version can be 'GIF89a' or 'GIF87a'.

GIF_WinHeight
GIF_WinHeight is the height of the window where GIF is showed.

GIF_WinWidth
GIF_WinWidth is the width of the window where GIF is showed.

GIF_XPos
GIF_XPos is the top-left X coordinate where the frame will be showed.

GIF_YPos
GIF_YPos is the top-left Y coordinate where the frame will be showed.

GIF_Comments
Contains the text comments contained in a GIF file.

.topic 36
JPEG_ColorSpace
Specify the loaded color space.
JPEG_RGB is separate RGB channels.
JPEG_GRAYLEV is unique intensity channel (gray levels).
JPEG_YCbCr three channels (CCIR Recommendation 601-1)
JPEG_CMYK four channels (Cyan Magenta Yellow Black) - linear convertion
JPEG_YCbCrK four channels (YCbCr and Black)

JPEG_DCTMethod
Specify the DCT method.
JPEG_ISLOW is slow but accurate integer algorithm.
JPEG_IFAST is faster, less accurate integer method.
JPEG_FLOAT is a floating-point method (machine dependent).

JPEG_OptimalHuffman
Specifies if jpeg compressor have to use an optimal huffman table (more compression)), instead standard table.

JPEG_Progressive
Specifies if this is a progressive jpeg.

JPEG_Quality
Quality factor, from 1 to 100. The higher the value, the better the image quality, and the larger resultant memory needed.

JPEG_Smooth
Smoothing factor (0 is none, 100 is max). If JPEG_Smooth is not zero, the jpeg compressor smooth the image before compress it. This improves compression.

JPEG_Scale
JPEGScale defines the sizes of loaded JPEG image. This proprety affects the speed of load.
Allowed values are:
JPEG_AUTOCALC : self calculates JPEGScale to mach Params.Width and Params.Height properties;
JPEG_FULLSIZE : full size image (default). Slow loading.
JPEG_HALF : 1/2 of the full size;
JPEG_QUARTER : 1/4 of the full size;
JPEG_EIGHTH : 1/8 of the full size. Very fast loading.

JPEG_MarkerList
JPEG_MarkerList contains a list of markers contained in a JPEG file. JPEG markers can contains text, objects and images. Applications can read raw markers from JPEG_MarkerList.

JPEG_WarningTot
JPEG_WarningTot is the count of all warnings encountered during loading a Jpeg. We suggest to use Aborting to see if the image is corrupted.

JPEG_WarningCode
JPEG_WarningCode is the last warning code encountered during loading a Jpeg.

JPEG_OriginalWidth
JPEG_OriginalWidth specifies the original width when the jpeg image is scaled (using JPEG_Scale).

JPEG_OriginalHeight
JPEG_OriginalHeight specifies the original height when the jpeg image is scaled (using JPEG_Scale).

.topic 38
JPEG2000_ColorSpace
Specifies the loaded color space.
Allowed values:
J2000_GRAYLEV : gray scale image
J2000_RGB : RGB image
J2000_YcbCr : YcbCr image (currently supported only for load)

JPEG2000_Rate
Specifies the compression rate to apply. Allowed values from 0 to 1, where 1 is no compression (lossless mode).

JPEG2000_ScalableBy
Specifies the progression order.
It can be:
J2000_Rate : layer-resolution-component-position (LRCP) progressive (i.e., rate scalable)
J2000_Resolution : resolution-layer-component-position (RLCP) progressive (i.e., resolution scalable)

.topic 40
PCX_Compression
PCX_Compression is the compression type for PCX image format.
PCX_UNCOMPRESSED is uncompressed PCX (incompatible with most PCX readers).
PCX_RLE is compressed PCX (standard PCX).

PCX_Version
PCX version (5 is the default).

.topic 42
TIFF_Compression
Specifies the compression type for TIFF image format.
TIFF_UNCOMPRESSED is uncompressed TIFF
TIFF_CCITT1D is bilevel Huffman compression.
TIFF_G3FAX1D is bilevel Group 3 CCITT compression, monodimensional.
TIFF_G3FAX2D is bilevel Group 3 CCITT compression, bidimensional.
TIFF_G4FAX is bilevel Group 4 CCITT compression, bidimensional.
TIFF_OLDJPEG is ver.6.0 jpeg compression (unsupported).
TIFF_JPEG is jpeg compression (unsupported).
TIFF_PACKBITS is RLE compression.
TIFF_UNKNOWN is an unknown compression

TIFF_DocumentName
Specifiy the document name field of a TIFF image format.

TIFF_EnableAdjustOrientation
When TIFF_EnableAdjustOrientation is True program rotate loaded image as specified in the TIFF file.

TIFF_ImageDescription
Specifiy the image description field of a TIFF image format.

TIFF_ImageIndex
TIFF_ImageIndex is the index (from 0) of the image.

TIFF_ImageCount
Specifies the image count of the last TIFF loaded.

TIFF_PageCount
Number of pages in TIFF file.

TIFF_PageName
Page name field in TIFF image format.

TIFF_PageNumber
Page number.

TIFF_PhotometInterpret
Photometric interpretation.
TIFF_WHITEISZERO
TIFF_BLACKISZERO
TIFF_RGB
TIFF_RGBPALETTE
TIFF_TRANSPMASK
TIFF_CMYK
TIFF_YCBCR
TIFF_CIELAB

TIFF_PlanarConf
Planar configuration.

TIFF_XPos
X top-left position of the original scanned image.

TIFF_YPos
Ytop-left position of the original scanned image.

TIFF_Orientation
The orientation of the original image.
Allowed values:
1 = The 0th row represents the visual top of the image, and the 0th column represents the visual left-hand side.
2 = The 0th row represents the visual top of the image, and the 0th column represents the visual right-hand side.
3 = The 0th row represents the visual bottom of the image, and the 0th column represents the visual right-hand side.
4 = The 0th row represents the visual bottom of the image, and the 0th column represents the visual left-hand side.
5 = The 0th row represents the visual left-hand side of the image, and the 0th column represents the visual top.
6 = The 0th row represents the visual right-hand side of the image, and the 0th column represents the visual top.
7 = The 0th row represents the visual right-hand side of the image, and the 0th column represents the visual bottom.
8 = The 0th row represents the visual left-hand side of the image, and the 0th column represents the visual bottom.

.topic 46
CUR_ImageIndex
The index (from 0) of the image. A CUR  file can contains multple images inside.

CUR_XHotSpot
The hot spot point of the cursor image.

CUR_YHotSpot
The hot spot point of the cursor image.

CUR_Background
CUR_Background is the background color where to merge loaded image.

.topic 48
ICO_ImageIndex
The index (from 0) of the image. An ICO file can contains multple images inside.

ICO_Background
ICO_Background is the background color where to merge loaded image.

.topic 50
PNG_Interlaced
If True the image is interlaced.

PNG_Background
Specifies the background color of the image.

PNG_Filter
Set the filter to apply. This can have a significant impact on the size and encoding speed and a somewhat lesser impact on the decoding speed of an image.
PNG_FILTER_NONE
PNG_FILTER_SUB
PNG_FILTER_PAETH

PNG_Compression
PNG_Compression changes how much time PNG-compressor spends on trying to compress the image data.
This property accept values from 0 (no compression) to 9 (best compression).

.topic 52
TGA_XPos
TGA_XPos is the top-left X coordinate where the image will be showed.

TGA_YPos
TGA_YPos is the top-left Y coordinate where the image will be showed.

TGA_Compressed
Set TGA_Compressed property to True to compress TGA image (RLE compression).

TGA_Descriptor
TGA_Descriptor contains the descriptor of the TGA file.

TGA_Author
TGA_Author contains the author name of the TGA file.

TGA_Date
TGA_Date contains the date/time creation of the TGA file.

TGA_ImageName
TGA_ImageName contains the image name of the TGA file.

TGA_Background
TGA_Background contains the image background (or transparency) color.

TGA_AspectRatio
TGA_AspectRatio contains the pixel aspect ratio (pixel width/height) of the TGA image

TGA_Gamma
TGA_Gamma contains the gamma value of the TGA image

TGA_GrayLevel
If TGA_GrayLevel is True the image will be saved as gray levels.

.topic 54
PXM_Comments
PXM_Comments contains a list of the comments found inside (or to write in) PPM, PBM or PGM file.

.topic 56
IPTC_Info contains a list of IPTC informations contained in a file.
IPTC records can contains text, objects and images.
Applications can read informations from IPTC_Info.

Each IPTC_Info item has a record number and a dataset number.
These values specify the type of datas contained in the item, according to IPTC – NAA Information Intechange Model Version 4 (look at www.iptc.org).

.topic 58
EXIF_ImageDescription
Describes the image

EXIF_Model
Shows model number of digicam

EXIF_Orientation
The orientation of the camera relative to the scene, when the image was captured
1 top left side
2 top right side
3 bottom right side
4 bottom left side
5 left side top
6 right side top
7 right side bottom
8 left side bottom

EXIF_XResolution, EXIF_YResolution
Display/Print resolution of image.
Default value is 1/72inch, but it has no mean because personal computer doesn't use this value to display/print out.

EXIF_ResolutionUnit
Unit of XResolution/YResolution.
1 means no-unit
2 means inch
3 means centimeter

EXIF_Software
Shows firmware(internal software of digicam) version number

EXIF_DateTime
Date/Time of image was last modified.
Data format is "YYYY:MM:DD HH:MM:SS". If clock has not set or digicam doesn't have clock, the field may be filled with spaces. In usual, it has the same value of DateTimeOriginal

EXIF_WhitePoint
Defines chromaticity of white point of the image.
If the image uses CIE Standard Illumination D65(known as international standard of 'daylight'), the values are '3127/10000,3290/10000'.

EXIF_PrimaryChromaticities
Defines chromaticity of the primaries of the image.
If the image uses CCIR Recommendation 709 primaries, values are '640/1000,330/1000,300/1000,600/1000,150/1000,0/1000'.

EXIF_YCbCrCoefficients
When image format is YCbCr, this value shows a constant to translate it to RGB format.
In usual, values are '0.299/0.587/0.114'.

EXIF_YCbCrPositioning
When image format is YCbCr and uses 'Subsampling' (cropping of chroma data, all the digicam do that), defines the chroma sample point of subsampling pixel array.
1 means the center of pixel array
2 means the datum point.

EXIF_ReferenceBlackWhite
Shows reference value of black point/white point.
In case of YCbCr format, first 2 show black/white of Y, next 2 are Cb, last 2 are Cr. In case of RGB format, first 2 show black/white of R, next 2 are G, last 2 are B.

EXIF_Copyright
Shows copyright information

EXIF_ExposureTime
Exposure time (reciprocal of shutter speed). Unit is second.

EXIF_FNumber
The actual F-number(F-stop) of lens when the image was taken.

EXIF_ExposureProgram
Exposure program that the camera used when image was taken.
1 means manual control
2 program normal
3 aperture priority
4 shutter priority
5 program creative (slow program)
6 program action(high-speed program)
7 portrait mode
8 landscape mode.

EXIF_ISOSpeedRatings
CCD sensitivity equivalent to Ag-Hr film speedrate.

EXIF_ExifVersion
Exif version number.
If the picture is based on Exif V2.1, value is "0210".

EXIF_DateTimeOriginal
Date/Time of original image taken.
This value should not be modified by user program. Data format is "YYYY:MM:DD HH:MM:SS". If clock has not set or digicam doesn't have clock, the field may be filled with spaces. In the Exif standard, this tag is optional, but it is mandatory for DCF.

EXIF_DateTimeDigitized
Date/Time of image digitized.
Usually, it contains the same value of DateTimeOriginal. Data format is "YYYY:MM:DD HH:MM:SS". If clock has not set or digicam doesn't have clock, the field may be filled with spaces. In the Exif standard, this tag is optional, but it is mandatory for DCF.

EXIF_CompressedBitsPerPixel
The average compression ratio of JPEG (rough estimate)

EXIF_ShutterSpeedValue
Shutter speed by APEX value.
To convert this value to ordinary 'Shutter Speed'; calculate this value's power of 2, then reciprocal.
For example, if the ShutterSpeedValue is '4', shutter speed is 1/(24)=1/16 second.

EXIF_ApertureValue
The actual aperture value of lens when the image was taken. Unit is APEX.
To convert this value to ordinary F-number (F-stop), calculate this value's power of root 2 (=1.4142).
For example, if the ApertureValue is '5', F-number is 1.41425 = F5.6.

EXIF_BrightnessValue
Brightness of taken subject, unit is APEX.
To calculate Exposure(Ev) from BrigtnessValue(Bv), you must add SensitivityValue(Sv).
Ev=Bv+Sv   Sv=log2(ISOSpeedRating/3.125)
ISO100:Sv=5, ISO200:Sv=6, ISO400:Sv=7, ISO125:Sv=5.32.

EXIF_ExposureBiasValue
Exposure bias(compensation) value of taking picture. Unit is APEX(EV).

EXIF_MaxApertureValue
Maximum aperture value of lens.
You can convert to F-number by calculating power of root 2 (same process of ApertureValue).

EXIF_SubjectDistance
Distance to focus point, unit is meter.

EXIF_MeteringMode
Exposure metering method.
0 means unknown
1 average
2 center weighted average
3 spot
4 multi-spot
5 multi-segment
6 partial
255 other.

EXIF_LightSource
Light source, actually this means white balance setting.
0 means unknown
1 daylight
2 fluorescent
3 tungsten
10 flash
17 standard light A
18 standard light B
19 standard light C
20 D55
21 D65
22 D75
255 other.

EXIF_Flash
0 means flash did not fire
1 flash fired
5 flash fired but strobe return light not detected
7 flash fired and strobe return light detected

EXIF_FocalLength
Focal length of lens used to take image. Unit is millimeter.

EXIF_SubsecTime, EXIF_SubsecTimeOriginal, EXIF_SubsecTimeDigitized
Some of digicam can take 2~30 pictures per second, but DateTime/DateTimeOriginal/DateTimeDigitized tag can't record the sub-second time. SubsecTime tag is used to record it.
For example, DateTimeOriginal = "1996:09:01 09:15:30",
SubSecTimeOriginal = "130",
Combined original time is "1996:09:01 09:15:30.130"

EXIF_FlashPixVersion
Stores FlashPix version.
If the image data is based on FlashPix formar Ver.1.0, value is "0100".

EXIF_ColorSpace
Defines Color Space. DCF image must use sRGB color space so value is always '1'. If the picture uses the other color space, value is '65535':Uncalibrated.

EXIF_ExifImageWidth, EXIF_ExifImageHeight
Size of main image.

EXIF_RelatedSoundFile
If this digicam can record audio data with image, shows name of audio data.

EXIF_FocalPlaneXResolution, EXIF_FocalPlaneYResolution
Pixel density at CCD's position.
If you have MegaPixel digicam and take a picture by lower resolution(e.g.VGA mode), this value is re-sampled by picture resolution. In such case, FocalPlaneResolution is not same as CCD's actual resolution.

EXIF_FocalPlaneResolutionUnit
Unit of FocalPlaneXResoluton/FocalPlaneYResolution.
1 means no-unit
2 inch
3 centimeter.

Note:Some of Fujifilm's digicam(e.g.FX2700,FX2900,Finepix4700Z/40i etc) uses value '3' so it must be 'centimeter', but it seems that they use a '8.3mm?'(1/3in.?) to their ResolutionUnit. Fuji's BUG? Finepix4900Z has been changed to use value '2' but it doesn't match to actual value also.

EXIF_ExposureIndex
Same as ISOSpeedRatings but data type is unsigned rational. Only Kodak's digicam uses this tag instead of ISOSpeedRating.

EXIF_SensingMethod
Shows type of image sensor unit. '2' means 1 chip color area sensor, most of all digicam use this type.

EXIF_FileSource
Indicates the image source. Value '03' means the image source is digital still camera.

EXIF_SceneType
Indicates the type of scene. Value '01' means that the image was directly photographed.

.topic 2
Work with program

.topic 7
General

.topic 9
License and Registration